On Wed, 26 Jul 2006 11:26:00 +0100
Chris Cannam <cannam@email-addr-hidden-day-breakfast.com> wrote:
> > vote++, i never cared for the more java style methodName convention.
>
> I think if your class is named LikeThis, then your method should be
> named likeThat (Java-style). If your method is named like_this, then
> your class should be named like_that (STL-style). Either is fine,
> but don't mix your dialects.
Oh well, this is precisely what i do. For classes i use FooBar. For
Objects i use foo_bar. and for methods, it's foo_bar, too.
class FooBar {
bool _yesno;
public:
FooBar (bool yesno) :
_yesno (yesno)
{
// ...
}
void foo_my_bar (bool yesno)
{
_yesno = yesno;
}
};
int main () {
FooBar foo_bar (false);
foo_bar.foo_my_bar (true);
}
It just strikes some aesthetic nerve in me. And this is something you
just cannot argue about. So to each his own i say :) And no, usually i
seperate header and implementation, too ;)
Regards,
Flo
-- Palimm Palimm! http://tapas.affenbande.orgReceived on Wed Jul 26 20:15:04 2006
This archive was generated by hypermail 2.1.8 : Wed Jul 26 2006 - 20:15:04 EEST