Re: [linux-audio-user] Fwd: Please test my MidiSport firmware loader

New Message Reply About this list Date view Thread view Subject view Author view Other groups

Subject: Re: [linux-audio-user] Fwd: Please test my MidiSport firmware loader
From: Clemens Ladisch (clemens_AT_ladisch.de)
Date: Fri Nov 15 2002 - 19:10:11 EET


Michal Seta wrote:
> Clemens Ladisch <clemens_AT_ladisch.de> wrote:
> > > Aconnect don`t show me any new midiports.
> >
> > It should.
>
> I have the same problem...
>
> Nov 15 09:35:38 komar kernel: hub.c: USB new device connect on bus1/1, assigned device number 7
> Nov 15 09:35:38 komar kernel: usb.c: USB device 7 (vend/prod 0x763/0x1001) is not claimed by any active driver.
> Nov 15 09:35:38 komar /etc/hotplug/usb.agent: Setup midisport_fw for USB product 763/1001/1
> Nov 15 09:35:38 komar /etc/hotplug/usb.agent: Module setup midisport_fw for USB product 763/1001/1
> Nov 15 09:35:38 komar /etc/hotplug/usb/midisport_fw: load /usr/share/usb/MidiSport2x2.ihx for 763/1001/1 to /proc/bus/usb/001/007

These messages are fine so far, but there should be more.

Please try to run the download utility manually:

        /sbin/fxload -s /usr/share/usb/MidiSportLoader.ihx -I /usr/share/usb/MidiSport2x2.ihx

too see if there are any error messages.

If the download was successful, the product ID should change from 0x1001
to 0x1002, i.e. /proc/bus/usb/devices should contain the line:
        P: Vendor=0763 ProdID=1002 Rev= 1.21

> And I've got snd-usb-audio loaded but I had to do it manually.
> ... alsa from cvs

snd-usb-audio should be loaded automatically. Please check that
/lib/modules/(version)/modules.usbmap contains a line with these numbers:
        snd-usb-audio ... 0x0763 0x1002 ...
If not, the ALSA drivers aren't installed correctly.

HTH
Clemens


New Message Reply About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Fri Nov 15 2002 - 19:10:02 EET