Re: [linux-audio-user] A couple of questions

From: Lee Revell <>
Date: Sun Apr 02 2006 - 20:11:26 EEST

On Sun, 2006-04-02 at 16:52 +0000, carmen wrote:
> >
> > > How can a user who just bought a USB audio device make it the
> > > default device?
> even if they do have the USB-audio module, likely the device will show up at hw:1.0.0. at which point the user has to either reorder the module loading via /etc/modules.d trickery, or do some asound.conf/rc magic to change the 'default' device to something 'sides hw:0.0.0. this isnt very intuitive..

Any reasonable distro will hide these implementation details from the

> >
> > System->Preferences->Sound then select the USB audio device from the
> > "Default sound card" menu
> let me guess, this changes the Gstreamer output device? woo, the Nautilus clicky-sounds go to the right place now!~!. if its actually changing the 'default' device for ALSA, that could be useful. which util is this?

No I believe it actually sets the ALSA "default" device by modifying the
ALSA config files or module config. I can't test it as I only have the
one card. This is a Gnome 2.14 feature.

> > > How does (or why must) a user know which module
> > > to use for his card?
> >
> > On what distro does a user have to know this? It should Just Work -
> admittedly ive only installed debian and gentoo in the past year. but both required manually looking up the module name from, then either manually editing /etc/make.conf and defining ALSA_CARDS, or downloading the alsa-driver tarball, and running make-kpkg and installing that with dpkg. neither one 'just worked'...

These are distro bugs, apparently Debian does not ship the driver for
your card (probably due to firmware loadibng issues), and of course
Gentoo requires you to do it manually.

> > They don't, if they use a newbie-friendly distro.
> neither SuSE or Ubuntu came up with my Echo card, even though its been rolled into the main alsa-driver tree for like a year now. maybe it has to do with the fact that its not in the kernel alsa driver and only the module version? something to do with firmware dependencies, perhaps..

File bug reports with your distro(s).

Received on Mon Apr 3 00:15:05 2006

This archive was generated by hypermail 2.1.8 : Mon Apr 03 2006 - 00:15:05 EEST