[linux-audio-user] ZynAddSubFX segfaults

From: <juuso.alasuutari@email-addr-hidden>
Date: Thu Aug 24 2006 - 23:21:08 EEST

Hello. I have a problem with ZynAddSubFX. After the last time I compiled it, it
segfaults on startup. Here's the part of Valgrind output that seems most

==19913== Thread 2:
==19913== Invalid read of size 4
==19913== at 0x80ABA8A: thread1(void*) (in /usr/bin/zynaddsubfx)
==19913== by 0x40D9156: (within /lib/libpthread-2.3.6.so)
==19913== by 0x4441E4D: clone (in /lib/libc-2.3.6.so)
==19913== Address 0x0 is not stack'd, malloc'd or (recently) free'd
==19913== Process terminating with default action of signal 11 (SIGSEGV)
==19913== Access not within mapped region at address 0x0
==19913== at 0x80ABA8A: thread1(void*) (in /usr/bin/zynaddsubfx)
==19913== by 0x40D9156: (within /lib/libpthread-2.3.6.so)
==19913== by 0x4441E4D: clone (in /lib/libc-2.3.6.so)

I'm out of luck trying to figure out what might have changed enough to cause
this behavior after the last time I compiled. On top of that I'm not a coder
and can only guess how to parse the sources for the cause of this.

I've built kernel version after the last time I compiled ZynAddSubFX,
the previous one was I haven't changed any kernel config settings.
I've also compiled a bunch of other stuff as well, but none of them are system
internals or direct dependencies to ZynAddSubFX.

I'd be grateful if anyone could help me debug this. It's a pity that ZynAddSubFX
is so lightly maintained - it's simply the best sounding Linux soft synth I've
ever tried, but unfortunately seems to have bugs left in it.

Juuso Alasuutari

This mail sent through L-secure: http://www.l-secure.net/
Received on Fri Aug 25 00:15:11 2006

This archive was generated by hypermail 2.1.8 : Fri Aug 25 2006 - 00:15:11 EEST